On the onset of this little write up, just want to warn that the images attached to this post are not really safe for work :)

Had a great opportunity to shoot with Kate again.  She's an amazing model to work with.  Her understanding of poses, and light is second to none.  We planned an outside setting for the shoot, but it being autumn in Alberta, the weather did not cooperate.  That's one thing that went wrong. 

Second I wanted to try flash photography with film, and not having a proper light meter... you know the rest.  It simply didn't work.  Eyeballing the light and manual camera settings is for pros, not people like me.  So that's another thing that failed.  Not completely, but it wasn't as good as I have envisioned. 

Thirdly, my Fuji XT1, which I brought as a backup to the film cameras, decided to be stubborn and refused to work with my lights.  I use radio poppers as a remote transmitter, and because some silly setting inside Fuji menu it just refused to work.  There is certain criteria you have to have for Fuji XT1 to operate strobes.  The camera cannot be on silent mode, it cannot have electronic shutter enabled etc. etc.  WHY?? The flash should work anyway.  You might get terrible results, but it should still work.  Nope, not this time. 

Even though it refused to work with speed lights, it got it's magic back, being able to work in very low light situation very very well.  The combination of the the excellent Fuji 56mm f1.2 lens and great high ISO performance of Fuji XT1, finished the session successfully. 

There was a lot more things that failed, like putting the film in the camera backwards, not being able to focus properly etc. etc.  Yes lack of experience... it was a great learning session though.  Thankfully Fuji came to the rescue.  Oh and one little tip... when in doubt push the film while developing.  It's not easy to recover underexposed images.